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I nstallation and Running I nstructionsfor Arda Proof of Concept
System

|. Introduction:

This documentation presents the installation notes for ARDA supervisor and analyst
interfaces. The main feature of the supervisor interfaceisto allow a supervisor to assign
atask to an analyst. A task isdefined to be aset of analyst’s name, project name, list of
positive examples, and list of negative examples. Upon submission of the task to the web
service, the service will invoke the classifier agent to generate a set of weight vectors that
determine the permission of each document for the analyst. An analyst assignedto a
particular task will be able to check hig/her task on the analyst interface by logging in and
clicking on the particular task from the list of tasks menu. The task will open with all the
documents within the communities of interest that the analyst is assigned to. Asthe
analyst clicks on each document, the authorization agent will determine whether it is
viewable to the analyst based on the generated weight vectors. We have shown the
accuracy of the classifier with minimal sets of positive and negative examples and the
performance of it.

Il. Installation Procedures:
a. Analyst Installation Instructions:
1. Savethe Analyst and Supervisor folder to C:/.
a. The Analyst folder should contain the arda2.war file and “build” folder.
b. The Supervisor folder should contain the “bin” folder, which includes the
executable and relevant files.

2. Instal Sun Application Server All-in-One Bundle.

a. Ontheweb, go to: http://java.sun.com/|2ee/1.4/downl oad.html#sdk

b. Scroll to “All-In-One Bundle” of “J2EE 1.4 SDK and Sun Java System
Application Server Platform Edition 8 2004Q4 Beta September 20, 2004.”

c. Click on Download.

d. Choose your platform and download using default settings

e. Atthe“Admin Configuration” interface enter a password for the Administrator
and choose “Don’'t prompt for Admin. User Name.”

3. Oncetheinstallation is complete, start the web server by going to Start -> All
Programs -> Sun Microsystems -> J2EE 1.4 SDK -> Start Default Server:



ﬁ Start Default Server

Starting Domain domainl, please wait.

Log redirected to C:SSun“AppServersdomains“domainlislogssserver.loyg.
Domain domainl started.

Press any key to continue . . . _

Figure 1: It shows that the default server has started

Press the enter key to exit out of the command prompt screen (close screen) shown in
Figure 1.

Open config.ini in C:/Analyst/build. Check the path to make sure it reflects the
placement of the Analyst and Supervisor folders, as such:

data=C:/Analyst/build/data
htmldata= C: /Analyst/build/htmldata
supervisor_dir= C:/Supervisor/bin

Go to Start -> All Programs -> Sun Microsystems -> J2EEE 1.4 SDK -> Deploytool
shown in Figure 2:
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Figure 2: Deployment Tool window

6. Inthe Deployment tool go to File -> Open. The Open Module will appear asin Figure
3
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T build
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File Marme: | |

Files of Type: |AII Module Files (.ear, jar, war, rar) - |
| Open Module | | Cancel |

Figure 3: Open Module window

7. Select arda2.war. After the arda2 module has been loaded, select “Edit Contents...”
in Deployment Tool as shown in Figure 4. The Edit Contents of arda2 Window will
appear asin Figure 5:
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Flgure 4: After arda2 war has been loaded, the Files hierarchy will show arda2 and its associated
servelets and web service.
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Figure 5: Edit Contents window of arda2

8. Inthelower panel select “build” and then click on “Remove.” Answer “Yes’ in the
Confirmation Dialog box.

9. Inthe upper pane select c:\Analyst\build and click on “Add.” Answer “Yesto All” in
the Confirmation Dialog box. Click on “OK” in the “Edit Contents of Arda2” GUI.

10. Inthe Deployment Tool, go to Tools -> Deploy. “ The Deploy Module arda2” GUI as
in Figure 6 will appear:

- Deploy Module ardaz

Server:
|§Iocalhos‘t:4848 - |

-Connection Setting:
User Name:
| acdmin |
Pazsward:

| O || Cancel || Help. . |

Figure 6: Deploy Module login screen

11. The admin password should be stored by default. Enter it if it is not stored. Click on
“OK.”



If you receive the following error message in Figure 7, click on “ Cancel
Deployment.”

£ Confirm Save and Deploy

Thiz module has unzaved changes. These changes will be saved prior to deployvment.

EaveandDepIDy | | Cancel Deploymernt |

[ Dont sk me this agsin

Figure 7: Confirm Save and Deploy window

Y ou will need to manually start the server by clicking “ Start” shown in Figure 8.

£ Deployment Tool: localhost: 4848 EHE]EJ
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® I Files g
% O wasbvisrs i
3 ardaz :
@ Ardawebservices) Matme 1 Status
@ Bannersery | | farda2. Stopped |
@ CatalogSery
temBrowseSery
@ LoginZery
@ RequestSery
SelectProfile

Deployed Applications

@ @- Servers
7] lncalhost 4545 (nsts...

v
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Go to http://local host:8080/ardalserviceAVSDL to check to see that the service has been
installed successfully. There should be an xml describing the services.




b. Supervisor Installation I nstructions:

1. In C:/Supervisor/bin/ open configure.ini. Make sure the path of anayst_dir and
supervisor_dir reflect the placements of Analyst and Supervisor folders, as such:

anadyst_dir=C:\Analyst\build\
supervisor_dir = C: \Supervisor\bin\

2. Click on supervisor.exe to start the supervisor asin Figure 9:

™ Arda Assign Supervisor E]@

File
Create a Profile ] Review Denied Request l Delete Prnf\le] Log ]
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Praoject
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Figure 9: Supervisor interface before login




b-1. Supervisor Interface Feature 1 - Create a Profile:
1. Goto File -> Create Supervisor in Supervisor interface in Figure 10 to create a
supervisor’s account.

™ Create a Superviosr, |Z||E|[z|

Mame ||

Paszword |

Subrnit | Clear |

A

Figure 10: One can create a supervisor’slogin

2. Goto File-> Login in Supervisor interface to login. Choose a supervisor that is created
as shown in Figure 11:

E™ Login D@

e
Uzer D e !" Lagin
Fazswiord s Eléar
Forgot vour pagsword? A

Figure 11: Login window

3. The " Arda Assign Supervisor” GUI will ungreyed out as shown in Figure 12:
@ Arda Assign Supervisor B\EEJ

Eile
[Treale’s P?EI;HTEHJ Review Denied F\equest] Delete F'rofi\e} Log l

4. Now one can start assigning jobsto

‘wWelcome Supervisor garof. Create a Meed+to-Know Profile for:

e — analysts.
Community of Interest =
Project

Files in the Community of Interest
Documents and Files

Add to Positive Examples Add to Megative Example
Pasitive Examples Megative Examples
Figure 12: Ungreyed out supervisor interface
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Figure 13: Documents vary according to the selection of community of interest
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5. Click on “Create Profile’ to create the

profile. Profile creation can take some time,
depending on the size of the positive and
Einirs i g i negative sets.
6. By going to http://localhost:8080/arda and
logging in, the analyst can view his job
Fenove Posite RenoveNegsive assignment. Currently, the available analysts
= i are“kclee”, and “ywseo”. Their passwords are

the same as the username: for instance, the

password for “kclee” is“kclee.”

7. Select the project to view from the drop-down list of projects and click on “View” in
the analyst’ s interface shown in Figure 14.



Figure 14: Analyst interface
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8. Thelist of classified documents will be displayed asin Figure 15:
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Figure 15: Display of classified documents on the analyst interface
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b-2. Supervisor Interface Feature 2 — Delete a Profile

1. Click on “Delete Profile” tab as shown in Figure 16.

Figure 16: Delete Profile tab on the supervisor’ sinterface
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‘Welcome Supervisor kelee.  Delete Profile for:
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Time Stamp
Analyst
Praoject

Positive Examples

Meqative Examples

2. Select aprofile from the drop-down

menu list to view the profile to be deleted
in Figure 17:

Figure 17: Select aprofile to delete

[ Arda Assign Supervisor E@@

File

Cieate & Profle | Fieview Denied Fiequest DelelaProfil | Log |
Welooms Supervisor keles, Delets Profe for

Profie [

Delete Profile

Time Stamp 1026128
Analyst kelee
Project busiess

Positive Eamples

Business._trap_0.hirl
business_tmp_1,hirl
business._tmp_10.html
business_tmp_11.himl
business_tmp_12 html
business_tmp_12.himl
business_tmp_14.himl
business_tmp_15.himl
business._tmp_16. html
business_tmp_17. html
business_tmp_18 himl
business_tmp_13.html
business_tmp_2 hirl v

Negative Examples

election_tmp_0Lhim
election_tmp_1_himl
election_tmp_10 himl
eleclion_tmp_100Lhiml
election_tmp_1 1. huml
election_tmp_102 il
eleclion_tmp_103 himl
election_tmp_104. hm
elsclion_tmp_1 05 himl
election_tmp_1 06, hm
eleclion_tmp_107.himi a
election_tmp_1 06 huml

eleclion_tmp_10% himl

3. Click on “Delete Profile” to remove the profile or the task associated with an analyst.

4. Click on“Yes’ inthe“Are You Sure” Dialog Box in Figure 18 to delete profile:

Are You Sure?

.\:;.:’J Are wou sure you want to delete the profile

Yes Mo

Figure 18: Click Yesto delete the profile



b-3. Supervisor Interface Feature 3 — Grant Request to Retrain Classifier

1. Suppose the analyst hasfilled out arequest to view a document. The request can be
viewed by going to the supervisor’s “Review Denied Request” tab page in Figure 19:

™ Arda Assign Supervisor.

File

Denied Profile
Analyst

Project

Create aProfle Rievien Denied iequest | Defate Profie | Log |

Welcome Supervisor kelee.  Grant Denied Profile for

kelee
business

Check Docs/Files to Grant Request to Read

busingss_tmp_10.iml

I” De/Select Al

EEX

2. Check the documents(s) to which the
supervisor would like to grant access
request.

3. Click on “Submit.” The classifier will be

w0 | | retrained with the additional set of

Reasons for Denying the Doc/Fils

documents. When the analyst logs in next
time, he/she should now be able to view the
document(s).

Submit

Figure 19: Review Denied Request tab on the
supervisor’sinterface

b-4. Supervisor Interface Feature 4 — L og

= arda Assign Supervisor

EEX

1. Click on “Log” tab as shown in Figure 20

Fie
Cieate a Frofe | Rieview Denied Request | Delete Frofie Log |
Welcame Supervisar kelee. View lags
Time Stamp__| Project | Diescription
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WARIEIE  kevin Superviser keles relrairing the profifor analyst kclee with
WATNEZ st Supervisor kcles reraining the profile for analyst kelee with busines..
WAL kevin Supsrviser koles relraiing the profi for analyst koles ith busines
WARIEZZ ke Superviser keles relrairing the profifor analys kclee with busines.
0131424 kevin Supervisor kcles reraining the profile for analyst kelee with busines..
WAL evin Supsrviser koles relrairing the profi for analyst koles it busines.
WAL kevin Superviser keles relrairing the profifor analyst kclee with busines.
WAL kevin Supervisor kcles reraining the profile for analyst kelee with busines..
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WAIEH e Supervisor kcles deleting the profie of erew_10191537.ml for 2na...
WARIEIE ke Supsrviser koles deleting the profc of kevin_1 D181 410l or an
WARIEIE st Superviser kclee delefing the profe o test_T0131357.smi for analy
W27 st Supervisor kelee creating  profe for analyst kcle
211628 test Supsrviser koles deleting the prof o test_10211428 smi for analy
021162 test Supervisor kelee creating 3 profle for analet kclee
W21 st Supervisor kcles deleting the profie of test_10211428.4m for analy.
0251240 sewch  Supsrisor gerof creating a profie for analat garof
0251342 help Supervisor garof creating a piofe for analyst kclee
2514 elevlion  Supemiscr garaf creating a profie for analyst garof
0251438 cloolion  Supsrvisor garof deleting the profi: of slection_ 10351435 s for a
0/251648  lawandgowl  Supervisor gerof creating a profe for analyst garof
/251455 elections  Supemiscr garaf creating a profe for analst kelee
2E11EE  business  Supsmisor koles oreating 3 profle for anayet kolee
/281215 busiess  Superviser kelee deleling the profie of busiess. 1026128.xm for an
10/261218  business  Supervisar kelee creating a profle for analyst kclee
0281225 business  Supervisor koles relraining the profifor analyst kolos vith
/28128 busiess  Supervisor kelee creating 3 profle for anast kclee
< |3
Resat Log

toview alog of al eventsthat are active for
the analyst(s) and supervisor:

2. Reset the log by clicking the button of
“Reset Log”.

Figure 20: Log tab on the supervisor’sinterface




